CVE-2013-4322 — tomcat
Fix: apache/tomcat@70dc3b2CVE-2013-4322 is a Improper Input Validation vulnerability in org.apache.tomcat:tomcat. A fix is available for org.apache.tomcat:tomcat — see the affected versions and patch details below.
Apache Tomcat Denial of Service vulnerability
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2013-4322.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
org.apache.tomcat:tomcat☕org.apache.tomcat:tomcat☕org.apache.tomcat:tomcatReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Apache Tomcat before 6.0.39, 7.x before 7.0.50, and 8.x before 8.0.0-RC10 processes chunked transfer coding without properly handling (1) a large total amount of chunked data or (2) whitespace characters in an HTTP header value within a trailer field, which allows remote attackers to cause a denial of service by streaming data. NOTE: this vulnerability exists because of an incomplete fix for CVE-2012-3544.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.tomcat:tomcat | all versions | 6.0.39org.apache.tomcat:tomcat:6.0.39 |
| ☕Maven | org.apache.tomcat:tomcat | ≥ 7.0.0&&< 7.0.50 | 7.0.50org.apache.tomcat:tomcat:7.0.50 |
| ☕Maven | org.apache.tomcat:tomcat | ≥ 8.0.0-RC1&&< 8.0.0-RC10 | 8.0.0-RC10org.apache.tomcat:tomcat:8.0.0-RC10 |
Affected Products
tomcatapacheDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.tomcat:tomcat, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.tomcat:tomcat to 6.0.39 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2013-4322 is resolved across your whole dependency graph.
Workarounds
Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat Enterprise Linux 6 | tomcat6-0:6.0.24-64.el6_5 | RHSA-2014:0429 |
| Red Hat Enterprise Linux 7 | tomcat-0:7.0.42-5.el7_0 | RHSA-2014:0686 |
| Red Hat JBoss Enterprise Web Server 2 for RHEL 5 | tomcat6-0:6.0.37-19_patch_04.ep6.el5 | RHSA-2014:0525 |
| Red Hat JBoss Enterprise Web Server 2 for RHEL 5 | tomcat7-0:7.0.40-13_patch_02.ep6.el5 | RHSA-2014:0526 |
| Red Hat JBoss Web Server 2.0 | tomcat7 | RHSA-2014:0527 |
| Red Hat JBoss Web Server 2.0 | tomcat6 | RHSA-2014:0528 |
Frequently Asked Questions
Is CVE-2013-4322 in your dependencies?
Find it across Maven, including transitive dependencies.