CVE-2013-4193 — plone
MEDIUMCVE-2013-4193 is a medium-severity (CVSS 5.9) CWE-264 vulnerability in plone. A fix is available for plone — see the affected versions and patch details below.
Plone Unrestricted Filed Manipulation vulnerability via content edit forms
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
plone🐍plone🐍ploneReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
typeswidget.py in Plone 2.1 through 4.1, 4.2.x through 4.2.5, and 4.3.x through 4.3.1 does not properly enforce the immutable setting on unspecified content edit forms, which allows remote attackers to hide fields on the forms via a crafted URL.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | plone | ≥ 2.1&&< 4.1.1 | 4.1.1pip install --upgrade 'plone==4.1.1' |
| 🐍PyPI | plone | ≥ 4.2&&< 4.2.6 | 4.2.6pip install --upgrade 'plone==4.2.6' |
| 🐍PyPI | plone | ≥ 4.3&&< 4.3.2 | 4.3.2pip install --upgrade 'plone==4.3.2' |
Affected Products
ploneploneDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for plone, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update plone to 4.1.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2013-4193 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2013-4193 in your dependencies?
Find it across PyPI, including transitive dependencies.