CVE-2013-2217 — suds
MEDIUMCVE-2013-2217 is a medium-severity (CVSS 6.2) CWE-59 vulnerability in suds. A fix is available for suds — see the affected versions and patch details below.
Improper Link Resolution Before File Access in Suds
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
suds🐍suds-py3Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
cache.py in Suds 0.4, when tempdir is set to None, allows local users to redirect SOAP queries and possibly have other unspecified impact via a symlink attack on a cache file with a predictable name in /tmp/suds/.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | suds | all versions | 1.0.0pip install --upgrade 'suds==1.0.0' |
| 🐍PyPI | suds-py3 | all versions | 1.4.4.1pip install --upgrade 'suds-py3==1.4.4.1' |
Affected Products
sudsjeff_ortelopensuseopensuseenterprise linuxredhatDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for suds, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update suds to 1.0.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2013-2217 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2013-2217 in your dependencies?
Find it across PyPI, including transitive dependencies.