CVE-2013-1842 — cms-core
HIGHCVE-2013-1842 is a high-severity (CVSS 7.4) SQL Injection vulnerability in typo3/cms-core. A fix is available for typo3/cms-core — see the affected versions and patch details below.
TYPO3 SQL injection vulnerability in the Extbase Framework
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
typo3/cms-core🐘typo3/cms-core🐘typo3/cms-core🐘typo3/cms-coreReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
SQL injection vulnerability in the Extbase Framework in TYPO3 4.5.x before 4.5.24, 4.6.x before 4.6.17, 4.7.x before 4.7.9, and 6.0.x before 6.0.3 allows remote attackers to execute arbitrary SQL commands via unspecified vectors, related to "the Query Object Model and relation values."
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | typo3/cms-core | ≥ 4.5.0&&< 4.5.24 | 4.5.24composer require typo3/cms-core:^4.5.24 |
| 🐘Packagist | typo3/cms-core | ≥ 4.6.0&&< 4.6.17 | 4.6.17composer require typo3/cms-core:^4.6.17 |
| 🐘Packagist | typo3/cms-core | ≥ 4.7.0&&< 4.7.9 | 4.7.9composer require typo3/cms-core:^4.7.9 |
| 🐘Packagist | typo3/cms-core | ≥ 6.0.0&&< 6.0.3 | 6.0.3composer require typo3/cms-core:^6.0.3 |
Affected Products
typo3typo3Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for typo3/cms-core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update typo3/cms-core to 4.5.24 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2013-1842 is resolved across your whole dependency graph.
Workarounds
Until you can upgrade, make sure every query built from user input uses parameterised statements or a prepared-statement API rather than string concatenation, and reduce the database account's privileges so an injected query cannot read or alter data beyond what the feature needs.
Frequently Asked Questions
Is CVE-2013-1842 in your dependencies?
Find it across Packagist, including transitive dependencies.