NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘 Packagist
Not in CISA KEV

CVE-2013-1831 — moodle

Fix: moodle/moodle@2c7cdbb

CVE-2013-1831 is a Information Exposure vulnerability in moodle/moodle. A fix is available for moodle/moodle — see the affected versions and patch details below.

Moodle reveals absolute path in exception message

Published
Updated
Affected
4 pkgs
Patched
3 / 4
Exploits
None indexed
Exploitation data as of Oct 26, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.6%probability of exploitation in next 30 days
Lower Risk+0.21%
Lower risk than most CVEs76th percentile — riskier than 76% of all scored CVEsHighest risk
0.00%0.70%1.40%2.10%0.4%1.6%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

4 pkgs affected
🐘moodle/moodle🐘moodle/moodle🐘moodle/moodle🐘moodle/moodle

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

lib/setuplib.php in Moodle through 2.1.10, 2.2.x before 2.2.8, 2.3.x before 2.3.5, and 2.4.x before 2.4.2 allows remote attackers to obtain sensitive information via an invalid request, which reveals the absolute path in an exception message.

Affected Packages

4 total 3 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistmoodle/moodleall versionsNo fix
🐘Packagistmoodle/moodle≥ 2.2.0&&< 2.2.82.2.8composer require moodle/moodle:^2.2.8
🐘Packagistmoodle/moodle≥ 2.3.0&&< 2.3.52.3.5composer require moodle/moodle:^2.3.5
🐘Packagistmoodle/moodle≥ 2.4.0&&< 2.4.22.4.2composer require moodle/moodle:^2.4.2

Affected Products

1 product · 101 configurations
Application
moodlemoodle
101 versions
1.1.11.2.01.2.11.3.01.3.11.3.21.3.31.3.41.4.11.4.21.4.31.4.4

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for moodle/moodle, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    A fix is available for CVE-2013-1831; check the affected-versions list above or the advisory for the patched release of moodle/moodle, then make sure no transitive dependency still pins the vulnerable range.

  3. Workarounds

    Assume what was exposed is already known: rotate any credential, token or key that the affected component could return, restrict the endpoint to callers that genuinely need it, and strip sensitive fields from responses and error output at the boundary rather than relying on the client not to read them.

Frequently Asked Questions

lib/setuplib.php in Moodle through 2.1.10, 2.2.x before 2.2.8, 2.3.x before 2.3.5, and 2.4.x before 2.4.2 allows remote attackers to obtain sensitive information via an invalid request, which reveals the absolute path in an exception message.
O3 Security · Impact-Aware SCA

Is CVE-2013-1831 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2013-1831: moodle Info Disclosure — Fixed in 2.2.8