CVE-2013-1814 — rave-core
Fix: apache/rave@546edbaCVE-2013-1814 is a Information Exposure vulnerability in org.apache.rave:rave-core. 3 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for org.apache.rave:rave-core — see the affected versions and patch details below.
Apache Rave information disclosure vulnerability
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
org.apache.rave:rave-core☕org.apache.rave:rave-web☕org.apache.rave:rave-portal-resourcesReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
The users/get program in the User RPC API in Apache Rave 0.11 through 0.20 allows remote authenticated users to obtain sensitive information about all user accounts via the offset parameter, as demonstrated by discovering password hashes in the password field of a response.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.rave:rave-core | ≥ 0.11&&< 0.20.1 | 0.20.1org.apache.rave:rave-core:0.20.1 |
| ☕Maven | org.apache.rave:rave-web | ≥ 0.11&&< 0.20.1 | 0.20.1org.apache.rave:rave-web:0.20.1 |
| ☕Maven | org.apache.rave:rave-portal-resources | ≥ 0.11&&< 0.20.1 | 0.20.1org.apache.rave:rave-portal-resources:0.20.1 |
Affected Products
raveapacheResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Apache Rave 0.11 < 0.20 - User Information Disclosure
by Andreas Guth · Mar 13, 2013
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.rave:rave-core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.rave:rave-core to 0.20.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2013-1814 is resolved across your whole dependency graph.
Workarounds
Assume what was exposed is already known: rotate any credential, token or key that the affected component could return, restrict the endpoint to callers that genuinely need it, and strip sensitive fields from responses and error output at the boundary rather than relying on the client not to read them.
Frequently Asked Questions
Is CVE-2013-1814 in your dependencies?
Find it across Maven, including transitive dependencies.