CVE-2013-1665 — django
Fix: django/django@1c60d07CVE-2013-1665 is a Information Exposure vulnerability in django. A fix is available for django — see the affected versions and patch details below.
XML External Entity (XXE) in Django
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
django🐍djangoReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
The XML libraries for Python 3.4, 3.3, 3.2, 3.1, 2.7, and 2.6, as used in OpenStack Keystone Essex and Folsom, Django, and possibly other products allow remote attackers to read arbitrary files via an XML external entity declaration in conjunction with an entity reference, aka an XML External Entity (XXE) attack.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | django | ≥ 1.3.0&&< 1.3.6 | 1.3.6pip install --upgrade 'django==1.3.6' |
| 🐍PyPI | django | ≥ 1.4.0&&< 1.4.4 | 1.4.4pip install --upgrade 'django==1.4.4' |
Affected Products
folsomopenstackkeystone essexopenstackDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for django, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update django to 1.3.6 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2013-1665 is resolved across your whole dependency graph.
Workarounds
Assume what was exposed is already known: rotate any credential, token or key that the affected component could return, restrict the endpoint to callers that genuinely need it, and strip sensitive fields from responses and error output at the boundary rather than relying on the client not to read them.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
This issue affects the versions of python as shipped with Red Hat Enterprise Linux 5, 6 and 7. Red Hat Product Security has rated this issue as having Moderate security impact. This issue is not currently planned to be addressed in future updates.
| Product | Fixed in | Advisory |
|---|---|---|
| OpenStack Folsom for RHEL 6 | openstack-keystone-0:2012.2.3-3.el6ost | RHSA-2013:0596 |
| OpenStack Folsom for RHEL 6 | openstack-nova-0:2012.2.3-4.el6ost | RHSA-2013:0657 |
| OpenStack Folsom for RHEL 6 | openstack-cinder-0:2012.2.3-4.el6ost | RHSA-2013:0658 |
| OpenStack Folsom for RHEL 6 | Django14-0:1.4.4-1.el6ost | RHSA-2013:0670 |
Frequently Asked Questions
Is CVE-2013-1665 in your dependencies?
Find it across PyPI, including transitive dependencies.