NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
MEDIUM severity

CVE-2013-0305 — django

MEDIUMFix: django/django@0e7861a

CVE-2013-0305 is a medium-severity (CVSS 4.3) Information Exposure vulnerability in django. A fix is available for django — see the affected versions and patch details below.

Django Data leakage via admin history log

Also known asGHSA-r7w6-p47g-vj53PYSEC-2013-16
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Oct 26, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.8%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs79th percentile — riskier than 79% of all scored CVEsHighest risk
0.00%0.77%1.55%2.32%0.2%1.8%Apr 26Sep 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
🐍django🐍django

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

The administrative interface for Django 1.3.x before 1.3.6, 1.4.x before 1.4.4, and 1.5 before release candidate 2 does not check permissions for the history view, which allows remote authenticated administrators to obtain sensitive object history information.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIdjango≥ 1.3&&< 1.3.61.3.6pip install --upgrade 'django==1.3.6'
🐍PyPIdjango≥ 1.4&&< 1.4.41.4.4pip install --upgrade 'django==1.4.4'

Affected Products

2 products · 17 configurations
OS
ubuntu linuxcanonical
4 versions
10.0411.1012.0412.10
Application
djangodjangoproject
8 versions
1.31.3.11.3.21.3.31.41.4.11.4.21.5

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for django, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update django to 1.3.6 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2013-0305 is resolved across your whole dependency graph.

  3. Workarounds

    Assume what was exposed is already known: rotate any credential, token or key that the affected component could return, restrict the endpoint to callers that genuinely need it, and strip sensitive fields from responses and error output at the boundary rather than relying on the client not to read them.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatModerate
ProductFixed inAdvisory
OpenStack Folsom for RHEL 6Django14-0:1.4.4-1.el6ostRHSA-2013:0670

Frequently Asked Questions

The administrative interface for Django 1.3.x before 1.3.6, 1.4.x before 1.4.4, and 1.5 before release candidate 2 does not check permissions for the history view, which allows remote authenticated administrators to obtain sensitive object history information.
O3 Security · Impact-Aware SCA

Is CVE-2013-0305 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2013-0305: django Info Disclosure — Fixed in 1.3.6