CVE-2013-0233 — devise
CVE-2013-0233 is a CWE-399 vulnerability in devise. 3 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for devise — see the affected versions and patch details below.
Devise does not properly perform type conversion when performing database queries
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
devise💎devise💎devise💎deviseReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects RubyGems packages — download data is not available via public APIs for these ecosystems.
Description
Devise gem 2.2.x before 2.2.3, 2.1.x before 2.1.3, 2.0.x before 2.0.5, and 1.5.x before 1.5.4 for Ruby, when using certain databases, does not properly perform type conversion when performing database queries, which might allow remote attackers to cause incorrect results to be returned and bypass security checks via unknown vectors, as demonstrated by resetting passwords of arbitrary accounts.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 💎RubyGems | devise | ≥ 2.2.0&&< 2.2.3 | 2.2.3bundle update devise --conservative |
| 💎RubyGems | devise | ≥ 2.1.0&&< 2.1.3 | 2.1.3bundle update devise --conservative |
| 💎RubyGems | devise | ≥ 2.0.0&&< 2.0.5 | 2.0.5bundle update devise --conservative |
| 💎RubyGems | devise | ≥ 1.5.0&&< 1.5.4 | 1.5.4bundle update devise --conservative |
Affected Products
opensuseopensusedeviseplataformatecResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for devise, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update devise to 2.2.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2013-0233 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2013-0233 in your dependencies?
Find it across RubyGems, including transitive dependencies.