NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
💎 RubyGems
Not in CISA KEV

CVE-2013-0162 — ruby_parser

Fix: seattlerb/ruby_parser@506c7e1

CVE-2013-0162 is a CWE-264 vulnerability in ruby_parser. A fix is available for ruby_parser — see the affected versions and patch details below.

ruby_parser allows local users to overwrite arbitrary files via symlink attack on temporary file with predictable name

Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Oct 25, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.4%probability of exploitation in next 30 days
Lower Risk+0.03%
Lower risk than most CVEs31th percentile — riskier than 31% of all scored CVEsHighest risk
0.00%0.29%0.58%0.87%0.1%0.4%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

1 pkg affected
💎ruby_parser

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects RubyGems packages — download data is not available via public APIs for these ecosystems.

Description

The diff_pp function in lib/gauntlet_rubyparser.rb in the ruby_parser gem 3.1.1 and earlier for Ruby allows local users to overwrite arbitrary files via a symlink attack on a temporary file with a predictable name in /tmp.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
💎RubyGemsruby_parser≥ 2.0.2&&< 3.1.23.1.2bundle update ruby_parser --conservative

Affected Products

1 product · 29 configurations
Application
ruby parserryan_davis
≤ 3.1.1
28 versions
1.0.02.0.02.0.12.0.22.0.32.0.42.0.52.0.62.1.02.2.02.3.02.3.1

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for ruby_parser, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update ruby_parser to 3.1.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2013-0162 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatLow
ProductFixed inAdvisory
CloudForms for RHEL 6rubygem-activesupport-1:3.0.10-10.el6cfRHSA-2013:0548
Red Hat Subscription Asset Manager 1.2apache-commons-codec-0:1.7-2.el6_3RHSA-2013:0544
RHEL 6 Version of OpenShift Enterprisegraphviz-0:2.26.0-10.el6RHSA-2013:0582

Frequently Asked Questions

The `diff_pp` function in `lib/gauntlet_rubyparser.rb` in the ruby_parser gem 3.1.1 and earlier for Ruby allows local users to overwrite arbitrary files via a symlink attack on a temporary file with a predictable name in `/tmp`.
O3 Security · Impact-Aware SCA

Is CVE-2013-0162 in your dependencies?

Find it across RubyGems, including transitive dependencies.

CVE-2013-0162: ruby_parser — Fixed in 3.1.2