NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
💎
💎 RubyGems
Not in CISA KEV
HIGH severity

CVE-2012-6685 — nokogiri

HIGH

CVE-2012-6685 is a high-severity (CVSS 7.5) CWE-776 vulnerability in nokogiri. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for nokogiri — see the affected versions and patch details below.

Nokogiri is vulnerable to XML External Entity (XXE) attack

Also known asGHSA-6wj9-77wq-jq7p
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Nov 1, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
2.2%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs82th percentile — riskier than 82% of all scored CVEsHighest risk
0.00%0.91%1.81%2.72%0.3%2.2%May 26Aug 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
💎nokogiri

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects RubyGems packages — download data is not available via public APIs for these ecosystems.

Description

Nokogiri before 1.5.4 is vulnerable to XXE attacks

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
💎RubyGemsnokogiriall versions1.5.4bundle update nokogiri --conservative

Affected Products

8 products · 9 configurations
Application
nokogirinokogiri
< 1.5.4
range
Application
cloudforms management engineredhat
1 version
5.0
OS
enterprise mrgredhat
1 version
2.0
Application
openshiftredhat
1 version
2.0
Application
openstackredhat
2 versions
4.06.0
Application
openstack foremanredhat
all
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for nokogiri, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update nokogiri to 1.5.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2012-6685 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

Nokogiri before 1.5.4 is vulnerable to XXE attacks
O3 Security · Impact-Aware SCA

Is CVE-2012-6685 in your dependencies?

Find it across RubyGems, including transitive dependencies.

CVE-2012-6685: nokogiri XXE — Fixed in 1.5.4