CVE-2012-6112 — moodle
Fix: tinymce/tinymce_spellchecker_php@2291018CVE-2012-6112 is a CWE-264 vulnerability in moodle/moodle. A fix is available for moodle/moodle — see the affected versions and patch details below.
PHP Spellchecker addon for TinyMCE allows attackers to trigger arbitrary outbound HTTP requests
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
moodle/moodle🐘moodle/moodle🐘moodle/moodle🐘moodle/moodleReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
classes/GoogleSpell.php in the PHP Spellchecker (aka Google Spellchecker) addon before 2.0.6.1 for TinyMCE, as used in Moodle 2.1.x before 2.1.10, 2.2.x before 2.2.7, 2.3.x before 2.3.4, and 2.4.x before 2.4.1 and other products, does not properly handle control characters, which allows remote attackers to trigger arbitrary outbound HTTP requests via a crafted string.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | moodle/moodle | ≥ 2.1.0&&< 2.1.10 | 2.1.10composer require moodle/moodle:^2.1.10 |
| 🐘Packagist | moodle/moodle | ≥ 2.2.0&&< 2.2.7 | 2.2.7composer require moodle/moodle:^2.2.7 |
| 🐘Packagist | moodle/moodle | ≥ 2.3.0&&< 2.3.4 | 2.3.4composer require moodle/moodle:^2.3.4 |
| 🐘Packagist | moodle/moodle | ≥ 2.4.0&&< 2.4.1 | 2.4.1composer require moodle/moodle:^2.4.1 |
Affected Products
moodlemoodlespellchecker phptinymceDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for moodle/moodle, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update moodle/moodle to 2.1.10 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2012-6112 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2012-6112 in your dependencies?
Find it across Packagist, including transitive dependencies.