CVE-2012-5498 — plone
HIGHCVE-2012-5498 is a high-severity (CVSS 7.5) CWE-264 vulnerability in plone. A fix is available for plone — see the affected versions and patch details below.
Plone denial of service via Caching Bypass
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
plone🐍ploneReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
queryCatalog.py in Plone before 4.2.3 and 4.3 before beta 1 allows remote attackers to bypass caching and cause a denial of service via a crafted request to a collection.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | plone | all versions | 4.2.3pip install --upgrade 'plone==4.2.3' |
| 🐍PyPI | plone | ≥ 4.3a0&&< 4.3b1 | 4.3b1pip install --upgrade 'plone==4.3b1' |
Affected Products
ploneploneDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for plone, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update plone to 4.2.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2012-5498 is resolved across your whole dependency graph.
Workarounds
Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat Enterprise Linux 5 | conga-0:0.12.2-81.el5 | RHSA-2014:1194 |
Frequently Asked Questions
Is CVE-2012-5498 in your dependencies?
Find it across PyPI, including transitive dependencies.