CVE-2012-5491 — plone
MEDIUMCVE-2012-5491 is a medium-severity (CVSS 5.3) Information Exposure vulnerability in plone. A fix is available for plone — see the affected versions and patch details below.
Plone Information Disclosure
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
plone🐍ploneReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
z3c.form, as used in Plone before 4.2.3 and 4.3 before beta 1, allows remote attackers to obtain the default form field values by leveraging knowledge of the form location and the element id.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | plone | all versions | 4.2.3pip install --upgrade 'plone==4.2.3' |
| 🐍PyPI | plone | ≥ 4.3a0&&< 4.3b1 | 4.3b1pip install --upgrade 'plone==4.3b1' |
Affected Products
ploneploneDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for plone, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update plone to 4.2.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2012-5491 is resolved across your whole dependency graph.
Workarounds
Assume what was exposed is already known: rotate any credential, token or key that the affected component could return, restrict the endpoint to callers that genuinely need it, and strip sensitive fields from responses and error output at the boundary rather than relying on the client not to read them.
Frequently Asked Questions
Is CVE-2012-5491 in your dependencies?
Find it across PyPI, including transitive dependencies.