NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
HIGH severity

CVE-2012-5485 — plone

HIGH

CVE-2012-5485 is a high-severity (CVSS 7.2) Code Injection vulnerability in plone. A fix is available for plone — see the affected versions and patch details below.

Plone Code Injection vulnerability

Also known asPYSEC-2014-27
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
2.1%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs82th percentile — riskier than 82% of all scored CVEsHighest risk
0.10%0.93%1.76%2.59%0.6%2.1%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
🐍plone🐍plone

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

registerConfiglet.py in Plone before 4.2.3 and 4.3 before beta 1 allows remote attackers to execute Python code via unspecified vectors, related to the admin interface.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIploneall versions4.2.3pip install --upgrade 'plone==4.2.3'
🐍PyPIplone≥ 4.3a1&&< 4.3b14.3b1pip install --upgrade 'plone==4.3b1'

Affected Products

1 product · 72 configurations
Application
ploneplone
≤ 4.2.2
65 versions
1.01.0.11.0.21.0.31.0.41.0.51.0.62.02.0.12.0.22.0.32.0.4

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for plone, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update plone to 4.2.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2012-5485 is resolved across your whole dependency graph.

  3. Workarounds

    Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatModerate
ProductFixed inAdvisory
Red Hat Enterprise Linux 5conga-0:0.12.2-81.el5RHSA-2014:1194

Frequently Asked Questions

`registerConfiglet.py` in Plone before 4.2.3 and 4.3 before beta 1 allows remote attackers to execute Python code via unspecified vectors, related to the admin interface.
O3 Security · Impact-Aware SCA

Is CVE-2012-5485 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2012-5485: plone — Fixed in 4.2.3