NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕ Maven
Not in CISA KEV

CVE-2012-4418 — axis2

CVE-2012-4418 is a Improper Authentication vulnerability in org.apache.axis2:axis2. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for org.apache.axis2:axis2 — see the affected versions and patch details below.

Apache Axis2 Vulnerable to XML Signature wrapping attack

Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
6.0%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs93th percentile — riskier than 93% of all scored CVEsHighest risk
0.00%2.57%5.13%7.70%0.3%6.0%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

1 pkg affected
☕org.apache.axis2:axis2

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Apache Axis2 allows remote attackers to forge messages and bypass authentication via an "XML Signature wrapping attack."

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.apache.axis2:axis2all versions1.7.9org.apache.axis2:axis2:1.7.9

Affected Products

1 product · 1 configurations
Application
axis2apache
all
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.axis2:axis2, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.apache.axis2:axis2 to 1.7.9 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2012-4418 is resolved across your whole dependency graph.

  3. Workarounds

    Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.

Frequently Asked Questions

Apache Axis2 allows remote attackers to forge messages and bypass authentication via an "XML Signature wrapping attack."
O3 Security · Impact-Aware SCA

Is CVE-2012-4418 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2012-4418: axis2 — Fixed in 1.7.9