NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
MEDIUM severity

CVE-2012-2417 — pycrypto

MEDIUMFix: Legrandin/pycrypto@9f912f1

CVE-2012-2417 is a medium-severity (CVSS 5.3) CWE-310 vulnerability in pycrypto. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for pycrypto — see the affected versions and patch details below.

PyCrypto makes Use of Insufficiently Random Values

Also known asPYSEC-2012-16
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Oct 30, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
2.4%probability of exploitation in next 30 days
Lower Risk-0.03%
Lower risk than most CVEs84th percentile — riskier than 84% of all scored CVEsHighest risk
1.85%2.77%3.69%4.60%4.1%2.4%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐍pycrypto

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

PyCrypto before 2.6 does not produce appropriate prime numbers when using an ElGamal scheme to generate a key, which reduces the signature space or public key space and makes it easier for attackers to conduct brute force attacks to obtain the private key.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIpycryptoall versions2.6pip install --upgrade 'pycrypto==2.6'

Affected Products

1 product · 21 configurations
Application
pycryptodlitz
≤ 2.5
12 versions
1.0.01.0.11.0.21.11.92.02.0.12.1.02.22.32.42.4.1
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for pycrypto, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update pycrypto to 2.6 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2012-2417 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Frequently Asked Questions

PyCrypto before 2.6 does not produce appropriate prime numbers when using an ElGamal scheme to generate a key, which reduces the signature space or public key space and makes it easier for attackers to conduct brute force attacks to obtain the private key.
O3 Security · Impact-Aware SCA

Is CVE-2012-2417 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2012-2417: pycrypto — Fixed in 2.6