NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘 Packagist
Not in CISA KEV

CVE-2012-1296 — cms

Fix: jbroadway/elefant@1e38b1d

CVE-2012-1296 is a Cross-site Scripting (XSS) vulnerability in elefant/cms. A fix is available for elefant/cms — see the affected versions and patch details below.

Elefant CMS Multiple XSS Vulnerabilities

Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Oct 20, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.3%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs70th percentile — riskier than 70% of all scored CVEsHighest risk
0.02%0.61%1.19%1.78%0.5%1.3%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

2 pkgs affected
🐘elefant/cms🐘elefant/cms

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Multiple cross-site scripting (XSS) vulnerabilities in apps/admin/handlers/preview.php in Elefant CMS 1.0.x before 1.0.2-Beta and 1.1.x before 1.1.5-Beta allow remote attackers to inject arbitrary web script or HTML via the (1) title or (2) body parameter to admin/preview.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistelefant/cms≥ 1.0&&< 1.0.2-Beta1.0.2-Betacomposer require elefant/cms:^1.0.2-Beta
🐘Packagistelefant/cms≥ 1.1&&< 1.1.5-Beta1.1.5-Betacomposer require elefant/cms:^1.1.5-Beta

Affected Products

1 product · 5 configurations
Application
elefantcmselefantcms
≤ 1.0.1
3 versions
1.1.1_beta1.1.2_beta1.1.3_beta

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for elefant/cms, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update elefant/cms to 1.0.2-Beta or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2012-1296 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

Multiple cross-site scripting (XSS) vulnerabilities in `apps/admin/handlers/preview.php` in Elefant CMS 1.0.x before 1.0.2-Beta and 1.1.x before 1.1.5-Beta allow remote attackers to inject arbitrary web script or HTML via the (1) title or (2) body parameter to admin/preview.
O3 Security · Impact-Aware SCA

Is CVE-2012-1296 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2012-1296: cms XSS — Fixed in 1.0.2-Beta