CVE-2012-1159 is a medium-severity (CVSS 4.3) Information Exposure vulnerability in moodle/moodle. A fix is available for moodle/moodle — see the affected versions and patch details below.
Moodle included private user files in course backups
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
moodle/moodle🐘moodle/moodle🐘moodle/moodle🐘moodle/moodleReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
Moodle before 2.2.2 is vulnerable to information disclosure because course backups were including users' private files.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | moodle/moodle | ≥ 2.2&&< 2.2.2 | 2.2.2composer require moodle/moodle:^2.2.2 |
| 🐘Packagist | moodle/moodle | ≥ 2.1&&< 2.1.5 | 2.1.5composer require moodle/moodle:^2.1.5 |
| 🐘Packagist | moodle/moodle | ≥ 2.0&&< 2.0.8 | 2.0.8composer require moodle/moodle:^2.0.8 |
| 🐘Packagist | moodle/moodle | all versions | 1.9.17composer require moodle/moodle:^1.9.17 |
Affected Products
fedorafedoraprojectmoodlemoodleDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for moodle/moodle, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update moodle/moodle to 2.2.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2012-1159 is resolved across your whole dependency graph.
Workarounds
Assume what was exposed is already known: rotate any credential, token or key that the affected component could return, restrict the endpoint to callers that genuinely need it, and strip sensitive fields from responses and error output at the boundary rather than relying on the client not to read them.
Frequently Asked Questions
Is CVE-2012-1159 in your dependencies?
Find it across Packagist, including transitive dependencies.