NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

CVE-2012-1157 — moodle

MEDIUMFix: moodle/moodle@246c2cb

CVE-2012-1157 is a medium-severity (CVSS 4.3) Incorrect Default Permissions vulnerability in moodle/moodle. A fix is available for moodle/moodle — see the affected versions and patch details below.

Moodle default permissions too permissive

Published
Updated
Affected
4 pkgs
Patched
4 / 4
Exploits
None indexed
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.2%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs69th percentile — riskier than 69% of all scored CVEsHighest risk
0.08%0.63%1.17%1.72%0.6%1.2%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

4 pkgs affected
🐘moodle/moodle🐘moodle/moodle🐘moodle/moodle🐘moodle/moodle

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Moodle before 2.2.2 has a default repository capabilities issue where all repositories are viewable by all users by default

Affected Packages

4 total 4 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistmoodle/moodle≥ 2.2&&< 2.2.22.2.2composer require moodle/moodle:^2.2.2
🐘Packagistmoodle/moodle≥ 2.1&&< 2.1.52.1.5composer require moodle/moodle:^2.1.5
🐘Packagistmoodle/moodle≥ 2.0&&< 2.0.82.0.8composer require moodle/moodle:^2.0.8
🐘Packagistmoodle/moodleall versions1.9.17composer require moodle/moodle:^1.9.17

Affected Products

2 products · 4 configurations
OS
fedorafedoraproject
3 versions
151617
Application
moodlemoodle
< 2.2.2
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for moodle/moodle, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update moodle/moodle to 2.2.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2012-1157 is resolved across your whole dependency graph.

  3. Workarounds

    Close the privilege gap rather than the entry point: audit which accounts, roles and service identities can reach the affected operation, drop the component to the least privilege it actually needs, and review file and directory permissions created by earlier installs — a default left in place is what makes this reachable.

Frequently Asked Questions

Moodle before 2.2.2 default settings allowed all repositories to be viewable by all authenticated users.
O3 Security · Impact-Aware SCA

Is CVE-2012-1157 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2012-1157: moodle — Fixed in 2.2.2