CVE-2012-1154 — mod_cluster
CVE-2012-1154 is a CWE-264 vulnerability in org.jboss.mod_cluster:mod_cluster. A fix is available for org.jboss.mod_cluster:mod_cluster — see the affected versions and patch details below.
Improper Access Control in JBoss mod_cluster
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
org.jboss.mod_cluster:mod_clusterReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
mod_cluster 1.0.10 before 1.0.10 CP03 and 1.1.x before 1.1.4, as used in JBoss Enterprise Application Platform 5.1.2, when "ROOT" is set to excludedContexts, exposes the root context of the server, which allows remote attackers to bypass access restrictions and gain access to applications deployed on the root context via unspecified vectors.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.jboss.mod_cluster:mod_cluster | ≥ 1.1.0&&< 1.1.4 | 1.1.4org.jboss.mod_cluster:mod_cluster:1.1.4 |
Affected Products
jboss enterprise application platformredhatmod clusterredhatDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.jboss.mod_cluster:mod_cluster, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.jboss.mod_cluster:mod_cluster to 1.1.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2012-1154 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
| Product | Fixed in | Advisory |
|---|---|---|
| JBEWP 5 for RHEL 5 | mod_cluster-0:1.0.10-4.1.GA_CP02_patch01.ep5.el5 | RHSA-2012:1053 |
| Red Hat JBoss Enterprise Application Platform 5.1 | see advisory | RHSA-2012:1010 |
| Red Hat JBoss Enterprise Application Platform 5 for RHEL 4 | mod_cluster-0:1.0.10-4.GA_CP02_patch01.ep5.el4 | RHSA-2012:1052 |
| Red Hat JBoss Enterprise Web Server 1 for RHEL 5 | mod_cluster-0:1.0.10-4.1.GA_CP02_patch01.ep5.el5 | RHSA-2012:1166 |
| Red Hat JBoss Web Platform 5.1 | see advisory | RHSA-2012:1011 |
| Red Hat JBoss Web Server 1.0 | see advisory | RHSA-2012:1012 |
Frequently Asked Questions
Is CVE-2012-1154 in your dependencies?
Find it across Maven, including transitive dependencies.