NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
CRITICAL severity

CVE-2012-0805 — sqlalchemy

CRITICALFix: sqlalchemy/sqlalchemy@51fea2e

CVE-2012-0805 is a critical-severity (CVSS 9.8) SQL Injection vulnerability in sqlalchemy. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for sqlalchemy — see the affected versions and patch details below.

SQLAlchemy vulnerable to SQL injection

Also known asGHSA-hfg2-wf6j-x53pPYSEC-2012-9
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
2.9%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs87th percentile — riskier than 87% of all scored CVEsHighest risk
1.15%1.89%2.64%3.39%1.6%2.9%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐍sqlalchemy

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

Multiple SQL injection vulnerabilities in SQLAlchemy before 0.7.0b4, as used in Keystone, allow remote attackers to execute arbitrary SQL commands via the (1) limit or (2) offset keyword to the select function, or unspecified vectors to the (3) select.limit or (4) select.offset function.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIsqlalchemyall versions0.7.0b4pip install --upgrade 'sqlalchemy==0.7.0b4'

Affected Products

1 product · 14 configurations
Application
sqlalchemysqlalchemy
≤ 0.7.0
9 versions
0.6.00.6.10.6.20.6.30.6.40.6.50.6.60.6.70.7.0
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for sqlalchemy, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update sqlalchemy to 0.7.0b4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2012-0805 is resolved across your whole dependency graph.

  3. Workarounds

    Until you can upgrade, make sure every query built from user input uses parameterised statements or a prepared-statement API rather than string concatenation, and reduce the database account's privileges so an injected query cannot read or alter data beyond what the feature needs.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatModerate
ProductFixed inAdvisory
Red Hat Enterprise Linux 6python-sqlalchemy-0:0.5.5-3.el6_2RHSA-2012:0369

Frequently Asked Questions

Multiple SQL injection vulnerabilities in SQLAlchemy before 0.7.0b4, as used in Keystone, allow remote attackers to execute arbitrary SQL commands via the (1) limit or (2) offset keyword to the select function, or unspecified vectors to the (3) select.limit or (4) select.offset function.
O3 Security · Impact-Aware SCA

Is CVE-2012-0805 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2012-0805: sqlalchemy — Fixed in 0.7.0b4