CVE-2012-0393 — struts2-core
Fix: apache/struts@25e5006CVE-2012-0393 is a CWE-264 vulnerability in org.apache.struts:struts2-core. 4 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for org.apache.struts:struts2-core — see the affected versions and patch details below.
Apache Struts's ParameterInterceptor component does not prevent access to public constructors
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
org.apache.struts:struts2-core☕org.apache.struts.xwork:xwork-coreReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
The ParameterInterceptor component in Apache Struts before 2.3.1.1 does not prevent access to public constructors, which allows remote attackers to create or overwrite arbitrary files via a crafted parameter that triggers the creation of a Java object.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.struts:struts2-core | all versions | 2.3.1.1org.apache.struts:struts2-core:2.3.1.1 |
| ☕Maven | org.apache.struts.xwork:xwork-core | all versions | 2.2.3.1org.apache.struts.xwork:xwork-core:2.2.3.1 |
Affected Products
strutsapacheResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Apache Struts 2 < 2.3.1 - Multiple Vulnerabilities
by SEC Consult · Jan 6, 2012
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.struts:struts2-core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.struts:struts2-core to 2.3.1.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2012-0393 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2012-0393 in your dependencies?
Find it across Maven, including transitive dependencies.