NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘 Packagist
Not in CISA KEV

CVE-2011-4932 — impresspages

CVE-2011-4932 is a Code Injection vulnerability in impresspages/impresspages. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for impresspages/impresspages — see the affected versions and patch details below.

ImpressPages CMS eval injection vulnerability

Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Nov 2, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
3.9%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs90th percentile — riskier than 90% of all scored CVEsHighest risk
2.97%3.46%3.94%4.43%3.5%3.9%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

1 pkg affected
🐘impresspages/impresspages

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Eval injection vulnerability in ip_cms/modules/standard/content_management/actions.php in ImpressPages CMS 1.0.12 and possibly other versons before 1.0.13 allows remote attackers to execute arbitrary code via the cm_group parameter.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistimpresspages/impresspagesall versions1.0.13composer require impresspages/impresspages:^1.0.13

Affected Products

1 product · 1 configurations
Application
impresspages cmsimpresspages
1 version
1.0.12
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for impresspages/impresspages, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update impresspages/impresspages to 1.0.13 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2011-4932 is resolved across your whole dependency graph.

  3. Workarounds

    Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.

Frequently Asked Questions

Eval injection vulnerability in `ip_cms/modules/standard/content_management/actions.php` in ImpressPages CMS 1.0.12 and possibly other versons before 1.0.13 allows remote attackers to execute arbitrary code via the `cm_group` parameter.
O3 Security · Impact-Aware SCA

Is CVE-2011-4932 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2011-4932: impresspages RCE — Fixed in 1.0.13