NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕ Maven
Not in CISA KEV

CVE-2011-4905 — activemq-core

Fix: apache/activemq@3a71f8e

CVE-2011-4905 is a CWE-399 vulnerability in org.apache.activemq:activemq-core. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for org.apache.activemq:activemq-core — see the affected versions and patch details below.

Denial of Service in Apache ActiveMQ

Also known asGHSA-9wcx-326r-7j7w
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
8.5%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs95th percentile — riskier than 95% of all scored CVEsHighest risk
7.22%9.39%11.6%13.7%12.5%8.5%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

1 pkg affected
☕org.apache.activemq:activemq-core

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Apache ActiveMQ before 5.6.0 allows remote attackers to cause a denial of service (file-descriptor exhaustion and broker crash or hang) by sending many openwire failover:tcp:// connection requests.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.apache.activemq:activemq-coreall versions5.6.0org.apache.activemq:activemq-core:5.6.0

Affected Products

1 product · 32 configurations
Application
activemqapache
≤ 5.5.1
29 versions
1.11.21.31.41.52.02.13.03.13.23.2.13.2.2
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.activemq:activemq-core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.apache.activemq:activemq-core to 5.6.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2011-4905 is resolved across your whole dependency graph.

  3. Workarounds

    Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.

Frequently Asked Questions

Apache ActiveMQ before 5.6.0 allows remote attackers to cause a denial of service (file-descriptor exhaustion and broker crash or hang) by sending many openwire failover:tcp:// connection requests.
O3 Security · Impact-Aware SCA

Is CVE-2011-4905 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2011-4905: activemq-core DoS — Fixed in 5.6.0