CVE-2011-4858 — tomcat
CVE-2011-4858 is a CWE-399 vulnerability in org.apache.tomcat:tomcat. 2 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for org.apache.tomcat:tomcat — see the affected versions and patch details below.
Improper Input Validation in Apache Tomcat
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
org.apache.tomcat:tomcat☕org.apache.tomcat:tomcat☕org.apache.tomcat:tomcatReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Apache Tomcat before 5.5.35, 6.x before 6.0.35, and 7.x before 7.0.23 computes hash values for form parameters without restricting the ability to trigger hash collisions predictably, which allows remote attackers to cause a denial of service (CPU consumption) by sending many crafted parameters.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.tomcat:tomcat | ≥ 5.5.0&&< 5.5.35 | 5.5.35org.apache.tomcat:tomcat:5.5.35 |
| ☕Maven | org.apache.tomcat:tomcat | ≥ 6.0.0&&< 6.0.35 | 6.0.35org.apache.tomcat:tomcat:6.0.35 |
| ☕Maven | org.apache.tomcat:tomcat | ≥ 7.0.0&&< 7.0.23 | 7.0.23org.apache.tomcat:tomcat:7.0.23 |
Affected Products
tomcatapacheResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
MyBulletinBoard (MyBB) 1.1.5 - 'CLIENT-IP' SQL Injection
by rgod · Jul 15, 2006
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.tomcat:tomcat, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.tomcat:tomcat to 5.5.35 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2011-4858 is resolved across your whole dependency graph.
Workarounds
Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
| Product | Fixed in | Advisory |
|---|---|---|
| JBEWP 5 for RHEL 5 | jbossweb-0:2.1.12-3_patch_03.2.ep5.el5 | RHSA-2012:0076 |
| JBoss Communications Platform 5.1 | see advisory | RHSA-2012:0078 |
| JBoss Enterprise BRMS Platform 5.1 | see advisory | RHSA-2012:0325 |
| Red Hat Enterprise Linux 5 | tomcat5-0:5.5.23-0jpp.31.el5_8 | RHSA-2012:0474 |
| Red Hat Enterprise Linux 6 | tomcat6-0:6.0.24-36.el6_2 | RHSA-2012:0475 |
| Red Hat JBoss Enterprise Application Platform 4.3 | see advisory | RHSA-2012:0041 |
| Red Hat JBoss Enterprise Application Platform 5.1 | see advisory | RHSA-2012:0075 |
| Red Hat JBoss Enterprise Application Platform 5 for RHEL 5 | jbossweb-0:2.1.12-3_patch_03.2.ep5.el5 | RHSA-2012:0074 |
Frequently Asked Questions
Is CVE-2011-4858 in your dependencies?
Find it across Maven, including transitive dependencies.