NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍 PyPI
Not in CISA KEV

CVE-2011-4356 — celery

Fix: ask/celery#544

CVE-2011-4356 is a CWE-264 vulnerability in celery. A fix is available for celery — see the affected versions and patch details below.

Celery local privilege escalation vulnerability

Also known asGHSA-rpc6-h455-3rx5PYSEC-2011-17
Published
Updated
Affected
3 pkgs
Patched
3 / 3
Exploits
None indexed
Exploitation data as of Oct 26, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.3%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs26th percentile — riskier than 26% of all scored CVEsHighest risk
0.00%0.28%0.56%0.85%0.0%0.3%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

3 pkgs affected
🐍celery🐍celery🐍celery

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

Celery 2.1 and 2.2 before 2.2.8, 2.3 before 2.3.4, and 2.4 before 2.4.4 changes the effective id but not the real id during processing of the --uid and --gid arguments to celerybeat, celeryd_detach, celeryd-multi, and celeryev, which allows local users to gain privileges via vectors involving crafted code that is executed by the worker process.

Affected Packages

3 total 3 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIcelery≥ 2.1.0&&< 2.2.82.2.8pip install --upgrade 'celery==2.2.8'
🐍PyPIcelery≥ 2.3.0&&< 2.3.42.3.4pip install --upgrade 'celery==2.3.4'
🐍PyPIcelery≥ 2.4.0&&< 2.4.42.4.4pip install --upgrade 'celery==2.4.4'

Affected Products

1 product · 17 configurations
Application
celeryceleryproject
17 versions
2.1.02.2.02.2.12.2.22.2.32.2.42.2.52.2.62.2.72.3.02.3.12.3.2

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for celery, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update celery to 2.2.8 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2011-4356 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

Celery 2.1 and 2.2 before 2.2.8, 2.3 before 2.3.4, and 2.4 before 2.4.4 changes the effective id but not the real id during processing of the --uid and --gid arguments to celerybeat, celeryd_detach, celeryd-multi, and celeryev, which allows local users to gain privileges via vectors involving crafted code that is executed by the worker process.
O3 Security · Impact-Aware SCA

Is CVE-2011-4356 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2011-4356: celery — Fixed in 2.2.8