CVE-2011-4320 — ejabberd
Fix: processone/ejabberd@d3c4eabCVE-2011-4320 is a CWE-399 vulnerability in ejabberd. A fix is available for ejabberd — see the affected versions and patch details below.
Ejabberd DoS via malformed stanza
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
ejabberd💧ejabberdReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Hex packages — download data is not available via public APIs for these ecosystems.
Description
The mod_pubsub module (mod_pubsub.erl) in ejabberd 2.1.8 and 3.0.0-alpha-3 allows remote authenticated users to cause a denial of service (infinite loop) via a stanza with a publish tag that lacks a node attribute.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 💧Hex | ejabberd | all versions | 2.1.9mix deps.update ejabberd |
| 💧Hex | ejabberd | ≥ 3.0.0-alpha-1&&< 3.0.0-alpha-4 | 3.0.0-alpha-4mix deps.update ejabberd |
Affected Products
ejabberdprocess-oneDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for ejabberd, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update ejabberd to 2.1.9 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2011-4320 is resolved across your whole dependency graph.
Workarounds
Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
Frequently Asked Questions
Is CVE-2011-4320 in your dependencies?
Find it across Hex, including transitive dependencies.