CVE-2011-3190 — tomcat
Fix: apache/tomcat@a2538ceCVE-2011-3190 is a CWE-264 vulnerability in org.apache.tomcat:tomcat. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for org.apache.tomcat:tomcat — see the affected versions and patch details below.
Apache Tomcat Allows Remote Attackers to Spoof AJP Requests
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
org.apache.tomcat:tomcat☕org.apache.tomcat:tomcat☕org.apache.tomcat:tomcatReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Certain AJP protocol connector implementations in Apache Tomcat 7.0.0 through 7.0.20, 6.0.0 through 6.0.33, 5.5.0 through 5.5.33, and possibly other versions allow remote attackers to spoof AJP requests, bypass authentication, and obtain sensitive information by causing the connector to interpret a request body as a new request.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.tomcat:tomcat | ≥ 7.0.0&&< 7.0.21 | 7.0.21org.apache.tomcat:tomcat:7.0.21 |
| ☕Maven | org.apache.tomcat:tomcat | ≥ 6.0.0&&< 6.0.34 | 6.0.34org.apache.tomcat:tomcat:6.0.34 |
| ☕Maven | org.apache.tomcat:tomcat | ≥ 5.0.0&&< 5.5.34 | 5.5.34org.apache.tomcat:tomcat:5.5.34 |
Affected Products
tomcatapacheResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.tomcat:tomcat, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.tomcat:tomcat to 7.0.21 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2011-3190 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat Enterprise Linux 6 | tomcat6-0:6.0.24-35.el6_1 | RHSA-2011:1780 |
| Red Hat JBoss Enterprise Web Server 1 for RHEL 5 | tomcat5-0:5.5.33-27_patch_07.ep5.el5 | RHSA-2012:0680 |
| Red Hat JBoss Enterprise Web Server 1 for RHEL 5 | tomcat6-0:6.0.32-24_patch_07.ep5.el5 | RHSA-2012:0682 |
| Red Hat JBoss Web Server 1.0 | see advisory | RHSA-2012:0679 |
| Red Hat JBoss Web Server 1.0 | see advisory | RHSA-2012:0681 |
Frequently Asked Questions
Is CVE-2011-3190 in your dependencies?
Find it across Maven, including transitive dependencies.