CVE-2011-2204 — tomcat
Fix: apache/tomcat@763a56bCVE-2011-2204 is a Information Exposure vulnerability in org.apache.tomcat:tomcat. A fix is available for org.apache.tomcat:tomcat — see the affected versions and patch details below.
Insertion of Sensitive Information into Log File in Apache Tomcat
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
org.apache.tomcat:tomcat☕org.apache.tomcat:tomcat☕org.apache.tomcat:tomcatReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Apache Tomcat 5.5.x before 5.5.34, 6.x before 6.0.33, and 7.x before 7.0.19, when the MemoryUserDatabase is used, creates log entries containing passwords upon encountering errors in JMX user creation, which allows local users to obtain sensitive information by reading a log file.
This issue was fixed in Apache Tomcat 7.0.17 but the release votes for the 7.0.17 and 7.0.18 release candidates did not pass. Therefore, users must download 7.0.19 to obtain a version that includes a fix.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.tomcat:tomcat | ≥ 5.5.0&&< 5.5.34 | 5.5.34org.apache.tomcat:tomcat:5.5.34 |
| ☕Maven | org.apache.tomcat:tomcat | ≥ 6.0.0&&< 6.0.33 | 6.0.33org.apache.tomcat:tomcat:6.0.33 |
| ☕Maven | org.apache.tomcat:tomcat | ≥ 7.0.0&&< 7.0.19 | 7.0.19org.apache.tomcat:tomcat:7.0.19 |
Affected Products
tomcatapacheDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.tomcat:tomcat, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.tomcat:tomcat to 5.5.34 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2011-2204 is resolved across your whole dependency graph.
Workarounds
Assume what was exposed is already known: rotate any credential, token or key that the affected component could return, restrict the endpoint to callers that genuinely need it, and strip sensitive fields from responses and error output at the boundary rather than relying on the client not to read them.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
The Red Hat Security Response Team has rated this issue as having low security impact, a future update may address this flaw.
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat Enterprise Linux 5 | tomcat5-0:5.5.23-0jpp.22.el5_7 | RHSA-2011:1845 |
| Red Hat Enterprise Linux 6 | tomcat6-0:6.0.24-35.el6_1 | RHSA-2011:1780 |
| Red Hat JBoss Enterprise Web Server 1 for RHEL 5 | tomcat5-0:5.5.33-27_patch_07.ep5.el5 | RHSA-2012:0680 |
| Red Hat JBoss Enterprise Web Server 1 for RHEL 5 | tomcat6-0:6.0.32-24_patch_07.ep5.el5 | RHSA-2012:0682 |
| Red Hat JBoss Web Server 1.0 | see advisory | RHSA-2012:0679 |
| Red Hat JBoss Web Server 1.0 | see advisory | RHSA-2012:0681 |
Frequently Asked Questions
Is CVE-2011-2204 in your dependencies?
Find it across Maven, including transitive dependencies.