NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍 PyPI
Not in CISA KEV

CVE-2011-2185 — fabric

Fix: fabric/fabric@3445b56

CVE-2011-2185 is a CWE-59 vulnerability in fabric. A fix is available for fabric — see the affected versions and patch details below.

Fabric vulnerable to symlink attack on tmp files

Also known asGHSA-xwg2-qc6c-7c3qPYSEC-2026-808
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.3%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs26th percentile — riskier than 26% of all scored CVEsHighest risk
0.00%0.28%0.55%0.83%0.0%0.3%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

1 pkg affected
🐍fabric

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

Fabric before 1.1.0 allows local users to overwrite arbitrary files via a symlink attack on (1) a /tmp/fab.*.tar file or (2) certain other files in the top level of /tmp/.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIfabricall versions1.1.0pip install --upgrade 'fabric==1.1.0'

Affected Products

1 product · 11 configurations
Application
fabricfabfile
≤ 1.0.2
10 versions
0.90.9.10.9.20.9.30.9.40.9.50.9.60.9.71.0.01.0.1

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for fabric, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update fabric to 1.1.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2011-2185 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

Fabric before 1.1.0 allows local users to overwrite arbitrary files via a symlink attack on (1) a /tmp/fab.*.tar file or (2) certain other files in the top level of /tmp/.
O3 Security · Impact-Aware SCA

Is CVE-2011-2185 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2011-2185: fabric — Fixed in 1.1.0