NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍 PyPI
Not in CISA KEV

CVE-2011-0728 — loggerhead

CVE-2011-0728 is a Cross-site Scripting (XSS) vulnerability in loggerhead. A fix is available for loggerhead — see the affected versions and patch details below.

Loggerhead XSS via filename

Also known asGHSA-qjmg-77xh-7mjwPYSEC-2026-840
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.8%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs79th percentile — riskier than 79% of all scored CVEsHighest risk
0.00%0.78%1.55%2.33%0.4%1.8%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

1 pkg affected
🐍loggerhead

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

Cross-site scripting (XSS) vulnerability in templatefunctions.py in Loggerhead before 1.18.1 allows remote authenticated users to inject arbitrary web script or HTML via a filename, which is not properly handled in a revision view.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIloggerheadall versions1.18.1pip install --upgrade 'loggerhead==1.18.1'

Affected Products

1 product · 5 configurations
Application
loggerheadmichael_hudson-doyle
≤ 1.18
4 versions
1.61.6.11.101.17

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for loggerhead, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update loggerhead to 1.18.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2011-0728 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

Cross-site scripting (XSS) vulnerability in templatefunctions.py in Loggerhead before 1.18.1 allows remote authenticated users to inject arbitrary web script or HTML via a filename, which is not properly handled in a revision view.
O3 Security · Impact-Aware SCA

Is CVE-2011-0728 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2011-0728: loggerhead XSS — Fixed in 1.18.1