NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
HIGH severity

CVE-2011-0432 — pywebdav

HIGH

CVE-2011-0432 is a high-severity (CVSS 8.1) SQL Injection vulnerability in pywebdav. A fix is available for pywebdav — see the affected versions and patch details below.

PyWebDAV SQL Injection vulnerability

Also known asGHSA-69vw-jfq7-935gPYSEC-2011-7
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Oct 31, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.8%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs79th percentile — riskier than 79% of all scored CVEsHighest risk
0.52%1.12%1.71%2.31%1.0%1.8%May 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐍pywebdav

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

Multiple SQL injection vulnerabilities in the get_userinfo method in the MySQLAuthHandler class in DAVServer/mysqlauth.py in PyWebDAV before 0.9.4.1 allow remote attackers to execute arbitrary SQL commands via the (1) user or (2) pw argument. NOTE: some of these details are obtained from third party information.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIpywebdavall versions0.9.4.1pip install --upgrade 'pywebdav==0.9.4.1'

Affected Products

1 product · 10 configurations
Application
pywebdavsimon_pamies
≤ 0.9.4
9 versions
0.30.50.5.10.60.70.80.9.10.9.20.9.3

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for pywebdav, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update pywebdav to 0.9.4.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2011-0432 is resolved across your whole dependency graph.

  3. Workarounds

    Until you can upgrade, make sure every query built from user input uses parameterised statements or a prepared-statement API rather than string concatenation, and reduce the database account's privileges so an injected query cannot read or alter data beyond what the feature needs.

Frequently Asked Questions

Multiple SQL injection vulnerabilities in the get_userinfo method in the MySQLAuthHandler class in DAVServer/mysqlauth.py in PyWebDAV before 0.9.4.1 allow remote attackers to execute arbitrary SQL commands via the (1) user or (2) pw argument. NOTE: some of these details are obtained from third party information.
O3 Security · Impact-Aware SCA

Is CVE-2011-0432 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2011-0432: pywebdav SQL Injection — Fixed in 0.9.4.1