NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕ Maven
Not in CISA KEV

CVE-2010-3708 — drools-core

CVE-2010-3708 is a Improper Input Validation vulnerability in org.drools:drools-core. A fix is available for org.drools:drools-core — see the affected versions and patch details below.

Drools Improper Input Validation vulnerability allows remote attackers to execute arbitrary code in JBoss EAP

Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
3.0%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs87th percentile — riskier than 87% of all scored CVEsHighest risk
1.92%2.45%2.98%3.52%2.4%3.0%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

1 pkg affected
☕org.drools:drools-core

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

The serialization implementation in JBoss Drools in Red Hat JBoss Enterprise Application Platform (aka JBoss EAP or JBEAP) 4.3 before 4.3.0.CP09 and JBoss Enterprise SOA Platform 4.2 and 4.3 supports the embedding of class files, which allows remote attackers to execute arbitrary code via a crafted static initializer.

The maintainers of JBoss EAP patched the vulnerability by applying a fix from Drools 4.0.7.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.drools:drools-coreall versions4.0.7org.drools:drools-core:4.0.7

Affected Products

2 products · 21 configurations
Application
jboss enterprise application platformredhat
1 version
4.3.0
Application
jboss enterprise soa platformredhat
2 versions
4.2.04.3.0

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.drools:drools-core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.drools:drools-core to 4.0.7 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2010-3708 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatImportant
ProductFixed inAdvisory
Red Hat JBoss Enterprise Application Platform 4.3see advisoryRHSA-2010:0939
Red Hat JBoss Enterprise Application Platform 4.3 for RHEL 4glassfish-jaxb-0:2.1.4-1.17.patch04.ep1.el4RHSA-2010:0937
Red Hat JBoss Enterprise Application Platform 4.3 for RHEL 5glassfish-jaxb-0:2.1.4-1.17.patch04.ep1.el5RHSA-2010:0938
Red Hat JBoss SOA Platform 4.2see advisoryRHSA-2010:0940

Frequently Asked Questions

The serialization implementation in JBoss Drools in Red Hat JBoss Enterprise Application Platform (aka JBoss EAP or JBEAP) 4.3 before 4.3.0.CP09 and JBoss Enterprise SOA Platform 4.2 and 4.3 supports the embedding of class files, which allows remote attackers to execute arbitrary code via a crafted static initializer. The maintainers of JBoss EAP patched the vulnerability by applying a fix from Drools 4.0.7.
O3 Security · Impact-Aware SCA

Is CVE-2010-3708 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2010-3708: drools-core RCE — Fixed in 4.0.7