CVE-2010-3671 is a medium-severity (CVSS 6.5) CWE-384 vulnerability in typo3/cms-install. A fix is available for typo3/cms-install — see the affected versions and patch details below.
TYPO3 is vulnerable to Session Fixation
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
typo3/cms-install🐘typo3/cms-install🐘typo3/cms-install🐘typo3/cms-installReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
TYPO3 before 4.1.14, 4.2.x before 4.2.13, 4.3.x before 4.3.4 and 4.4.x before 4.4.1 is open to a session fixation attack which allows remote attackers to hijack a victim's session.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | typo3/cms-install | all versions | 4.1.14composer require typo3/cms-install:^4.1.14 |
| 🐘Packagist | typo3/cms-install | ≥ 4.2.0&&< 4.2.13 | 4.2.13composer require typo3/cms-install:^4.2.13 |
| 🐘Packagist | typo3/cms-install | ≥ 4.3.0&&< 4.3.4 | 4.3.4composer require typo3/cms-install:^4.3.4 |
| 🐘Packagist | typo3/cms-install | ≥ 4.4.0&&< 4.4.1 | 4.4.1composer require typo3/cms-install:^4.4.1 |
Affected Products
typo3typo3Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for typo3/cms-install, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update typo3/cms-install to 4.1.14 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2010-3671 is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Frequently Asked Questions
Is CVE-2010-3671 in your dependencies?
Find it across Packagist, including transitive dependencies.