NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
MEDIUM severity

CVE-2010-3300 — esapi

MEDIUM

CVE-2010-3300 is a medium-severity (CVSS 5.9) CWE-649 vulnerability in org.owasp.esapi:esapi. A fix is available for org.owasp.esapi:esapi — see the affected versions and patch details below.

Padding oracle attacks

Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.4%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs39th percentile — riskier than 39% of all scored CVEsHighest risk
0.00%0.32%0.63%0.95%0.2%0.4%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
☕org.owasp.esapi:esapi

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

It was found that all OWASP ESAPI for Java up to version 2.0 RC2 are vulnerable to padding oracle attacks.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.owasp.esapi:esapiall versions2.0GAorg.owasp.esapi:esapi:2.0GA

Affected Products

1 product · 3 configurations
Application
enterprise security api for javaowasp
< 2.0
1 version
2.0

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.owasp.esapi:esapi, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.owasp.esapi:esapi to 2.0GA or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2010-3300 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

It was found that all OWASP ESAPI for Java up to version 2.0 RC2 are vulnerable to padding oracle attacks.
O3 Security · Impact-Aware SCA

Is CVE-2010-3300 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2010-3300: esapi — Fixed in 2.0GA