NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
Withdrawn — this advisory has been retracted
📦
📦 Debian:10
Not in CISA KEV
MEDIUM severity

CVE-2010-2970 — moin

MEDIUM

CVE-2010-2970 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in moin. A fix is available for moin — see the affected versions and patch details below.

MoinMoin cross-site scripting (XSS) vulnerability

Also known asGHSA-gxh5-r8gp-pjc3PYSEC-2010-18
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
2.6%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs85th percentile — riskier than 85% of all scored CVEsHighest risk
0.01%1.05%2.10%3.14%0.6%2.6%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
📦moin

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Debian:10 packages — download data is not available via public APIs for these ecosystems.

Description

Multiple cross-site scripting (XSS) vulnerabilities in MoinMoin 1.9.x before 1.9.3 allow remote attackers to inject arbitrary web script or HTML via crafted content, related to (1) action/SlideShow.py, (2) action/anywikidraw.py, and (3) action/language_setup.py, a similar issue to CVE-2010-2487.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦Debian:10moinall versions1.9.3-1

Affected Products

1 product · 3 configurations
Application
moinmoinmoinmo
3 versions
1.9.01.9.11.9.2

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for moin, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update moin to 1.9.3-1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2010-2970 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

Multiple cross-site scripting (XSS) vulnerabilities in MoinMoin 1.9.x before 1.9.3 allow remote attackers to inject arbitrary web script or HTML via crafted content, related to (1) action/SlideShow.py, (2) action/anywikidraw.py, and (3) action/language_setup.py, a similar issue to CVE-2010-2487.
O3 Security · Impact-Aware SCA

Is CVE-2010-2970 in your dependencies?

Find it across Debian:10, including transitive dependencies.

CVE-2010-2970: moin XSS — Fixed in 1.9.3-1