CVE-2010-2103 — axis2
CVE-2010-2103 is a Cross-site Scripting (XSS) vulnerability in org.apache.axis2.wso2:axis2. 5 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for org.apache.axis2.wso2:axis2 — see the affected versions and patch details below.
Improper Neutralization of Input During Web Page Generation in Apache Axis2
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
org.apache.axis2.wso2:axis2Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Cross-site scripting (XSS) vulnerability in axis2-admin/axis2-admin/engagingglobally in the administration console in Apache Axis2/Java 1.4.1, 1.5.1, and possibly other versions, as used in SAP Business Objects 12, 3com IMC, and possibly other products, allows remote attackers to inject arbitrary web script or HTML via the modules parameter. NOTE: some of these details are obtained from third party information.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.axis2.wso2:axis2 | ≥ 1.4.1&&< 1.6.0 | 1.6.0org.apache.axis2.wso2:axis2:1.6.0 |
Affected Products
axis2apacheResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Apache Axis2 Administration Console - (Authenticated) Cross-Site Scripting
by Richard Brain · May 21, 2010
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.axis2.wso2:axis2, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.axis2.wso2:axis2 to 1.6.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2010-2103 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is CVE-2010-2103 in your dependencies?
Find it across Maven, including transitive dependencies.