CVE-2010-1622 — spring
Fix: spring-projects/spring-framework@3a5af35CVE-2010-1622 is a Code Injection vulnerability in org.springframework:spring. 6 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for org.springframework:spring — see the affected versions and patch details below.
Improper Control of Generation of Code ('Code Injection') in Spring Framework
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
org.springframework:spring☕org.springframework:springReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
SpringSource Spring Framework 2.5.x before 2.5.6.SEC02, 2.5.7 before 2.5.7.SR01, and 3.0.x before 3.0.3 allows remote attackers to execute arbitrary code via an HTTP request containing class.classLoader.URLs[0]=jar: followed by a URL of a crafted .jar file.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.springframework:spring | ≥ 2.5.0&&< 2.5.7 | 2.5.7org.springframework:spring:2.5.7 |
| ☕Maven | org.springframework:spring | ≥ 3.0.0&&< 3.0.3 | 3.0.3org.springframework:spring:3.0.3 |
Affected Products
fusion middlewareoraclespring frameworkspringsourceResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Spring Framework - Arbitrary code Execution
by Meder Kydyraliev · Jun 18, 2010
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.springframework:spring, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.springframework:spring to 2.5.7 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2010-1622 is resolved across your whole dependency graph.
Workarounds
Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
This issue did not affect the versions of the SpringSource Spring Framework, as shipped with JBoss Enterprise Application Platform v4.2.0, v4.3.0, or v.5.0.0.
| Product | Fixed in | Advisory |
|---|---|---|
| JBWFK 1.0.0 for RHEL 4 | jboss-wfk-1.0.0-uninstall-0:1.0.0-3.ep5.el4 | RHSA-2011:0175 |
Frequently Asked Questions
Is CVE-2010-1622 in your dependencies?
Find it across Maven, including transitive dependencies.