NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘 Packagist
Not in CISA KEV

CVE-2010-1618 — phpcas

Fix: apereo/phpCAS@0216331

CVE-2010-1618 is a Cross-site Scripting (XSS) vulnerability in apereo/phpcas. A fix is available for apereo/phpcas — see the affected versions and patch details below.

phpCAS client library and Moodle Cross-site Scripting vulnerability

Published
Updated
Affected
3 pkgs
Patched
3 / 3
Exploits
None indexed
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.8%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs79th percentile — riskier than 79% of all scored CVEsHighest risk
0.00%0.77%1.54%2.31%0.3%1.8%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

3 pkgs affected
🐘apereo/phpcas🐘moodle/moodle🐘moodle/moodle

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Cross-site scripting (XSS) vulnerability in the phpCAS client library before 1.1.0, as used in Moodle 1.8.x before 1.8.12 and 1.9.x before 1.9.8, allows remote attackers to inject arbitrary web script or HTML via a crafted URL, which is not properly handled in an error message.

Affected Packages

3 total 3 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistapereo/phpcasall versions1.1.0composer require apereo/phpcas:^1.1.0
🐘Packagistmoodle/moodle≥ 1.8.0&&< 1.8.121.8.12composer require moodle/moodle:^1.8.12
🐘Packagistmoodle/moodle≥ 1.9.0&&< 1.9.81.9.8composer require moodle/moodle:^1.9.8

Affected Products

2 products · 22 configurations
Application
phpcas client libraryja-sig
2 versions
1.0.01.0.1
Application
moodlemoodle
18 versions
1.8.11.8.21.8.31.8.41.8.51.8.61.8.71.8.81.8.91.8.101.8.111.9.1

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for apereo/phpcas, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update apereo/phpcas to 1.1.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2010-1618 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

Cross-site scripting (XSS) vulnerability in the phpCAS client library before 1.1.0, as used in Moodle 1.8.x before 1.8.12 and 1.9.x before 1.9.8, allows remote attackers to inject arbitrary web script or HTML via a crafted URL, which is not properly handled in an error message.
O3 Security · Impact-Aware SCA

Is CVE-2010-1618 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2010-1618: phpcas XSS — Fixed in 1.1.0