CVE-2010-1616 — moodle
Fix: moodle/moodle@55f5b2eCVE-2010-1616 is a security vulnerability in moodle/moodle. A fix is available for moodle/moodle — see the affected versions and patch details below.
Moodle is vulnerable to unauthorized new accounts creation
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
moodle/moodle🐘moodle/moodleReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
Moodle 1.8.x and 1.9.x before 1.9.8 can create new roles when restoring a course, which allows teachers to create new accounts even if they do not have the moodle/user:create capability.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | moodle/moodle | ≥ 1.8.0&&< 1.8.12 | 1.8.12composer require moodle/moodle:^1.8.12 |
| 🐘Packagist | moodle/moodle | ≥ 1.9.0&&< 1.9.8 | 1.9.8composer require moodle/moodle:^1.9.8 |
Affected Products
moodlemoodleDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for moodle/moodle, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update moodle/moodle to 1.8.12 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2010-1616 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2010-1616 in your dependencies?
Find it across Packagist, including transitive dependencies.