NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘 Packagist
Not in CISA KEV

CVE-2009-4963 — commerce

CVE-2009-4963 is a Cross-site Scripting (XSS) vulnerability in commerceteam/commerce. A fix is available for commerceteam/commerce — see the affected versions and patch details below.

Commerce extension for TYPO3 vulnerable to Cross-site Scripting

Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.8%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs58th percentile — riskier than 58% of all scored CVEsHighest risk
0.00%0.44%0.89%1.33%0.2%0.8%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

1 pkg affected
🐘commerceteam/commerce

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Cross-site scripting (XSS) vulnerability in the Commerce extension before 0.9.9 for TYPO3 allows remote authenticated users to inject arbitrary web script or HTML via unspecified vectors.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistcommerceteam/commerce≥ 0.9.6&&< 0.9.90.9.9composer require commerceteam/commerce:^0.9.9

Affected Products

1 product · 7 configurations
Application
commerce extensiontypo3
≤ 0.9.8
6 versions
0.8.320.8.350.9.00.9.50.9.60.9.7

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for commerceteam/commerce, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update commerceteam/commerce to 0.9.9 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2009-4963 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

Cross-site scripting (XSS) vulnerability in the Commerce extension before 0.9.9 for TYPO3 allows remote authenticated users to inject arbitrary web script or HTML via unspecified vectors.
O3 Security · Impact-Aware SCA

Is CVE-2009-4963 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2009-4963: commerce XSS — Fixed in 0.9.9