NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘 Packagist
Not in CISA KEV

CVE-2009-3633 — cms-core

Fix: TYPO3/typo3@51f3dd9

CVE-2009-3633 is a Cross-Site Request Forgery (CSRF) vulnerability in typo3/cms-core. A fix is available for typo3/cms-core — see the affected versions and patch details below.

TYPO3 API function vulnerable to Cross-site Scripting

Published
Updated
Affected
4 pkgs
Patched
3 / 4
Exploits
None indexed
Exploitation data as of Oct 24, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.9%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs61th percentile — riskier than 61% of all scored CVEsHighest risk
0.00%0.48%0.97%1.45%0.4%0.9%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

4 pkgs affected
🐘typo3/cms-core🐘typo3/cms-core🐘typo3/cms-core🐘typo3/cms-core

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Cross-site scripting (XSS) vulnerability in the t3lib_div::quoteJSvalue API function in TYPO3 4.0.13 and earlier, 4.1.x before 4.1.13, 4.2.x before 4.2.10, and 4.3.x before 4.3beta2 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors related to the sanitizing algorithm.

Affected Packages

4 total 3 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagisttypo3/cms-coreall versionsNo fix
🐘Packagisttypo3/cms-core≥ 4.1.0&&< 4.1.134.1.13composer require typo3/cms-core:^4.1.13
🐘Packagisttypo3/cms-core≥ 4.2.0&&< 4.2.104.2.10composer require typo3/cms-core:^4.2.10
🐘Packagisttypo3/cms-core≥ 4.3alpha1&&< 4.3beta24.3beta2composer require typo3/cms-core:^4.3beta2

Affected Products

1 product · 59 configurations
Application
typo3typo3
≤ 4.0.12
55 versions
0.1.21.0.141.11.1.11.1.091.1.101.2.01.3.01.3.23.03.3.x3.5

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for typo3/cms-core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    A fix is available for CVE-2009-3633; check the affected-versions list above or the advisory for the patched release of typo3/cms-core, then make sure no transitive dependency still pins the vulnerable range.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

Cross-site scripting (XSS) vulnerability in the `t3lib_div::quoteJSvalue` API function in TYPO3 4.0.13 and earlier, 4.1.x before 4.1.13, 4.2.x before 4.2.10, and 4.3.x before 4.3beta2 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors related to the sanitizing algorithm.
O3 Security · Impact-Aware SCA

Is CVE-2009-3633 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2009-3633: cms-core XSS — Fixed in 4.1.13