NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕ Maven
Not in CISA KEV

CVE-2009-0781 — tomcat

CVE-2009-0781 is a Cross-site Scripting (XSS) vulnerability in org.apache.tomcat:tomcat. A fix is available for org.apache.tomcat:tomcat — see the affected versions and patch details below.

Cross-site scripting in Apache Tomcat

Published
Updated
Affected
3 pkgs
Patched
1 / 3
Exploits
None indexed
Exploitation data as of Nov 1, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
9.7%probability of exploitation in next 30 days
Lower Risk+0.59%
Lower risk than most CVEs96th percentile — riskier than 96% of all scored CVEsHighest risk
0.67%15.7%30.7%45.8%37.3%9.7%May 26Aug 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

3 pkgs affected
☕org.apache.tomcat:tomcat☕org.apache.tomcat:tomcat☕org.apache.tomcat:tomcat

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Cross-site scripting (XSS) vulnerability in jsp/cal/cal2.jsp in the calendar application in the examples web application in Apache Tomcat 4.1.0 through 4.1.39, 5.5.0 through 5.5.27, and 6.0.0 through 6.0.18 allows remote attackers to inject arbitrary web script or HTML via the time parameter, related to "invalid HTML."

Affected Packages

3 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.apache.tomcat:tomcat≥ 4.1.0No fix
☕Mavenorg.apache.tomcat:tomcat≥ 5.5.0No fix
☕Mavenorg.apache.tomcat:tomcat≥ 6.0.0&&< 6.0.206.0.20org.apache.tomcat:tomcat:6.0.20

Affected Products

1 product · 85 configurations
Application
tomcatapache
83 versions
4.1.04.1.14.1.24.1.34.1.44.1.54.1.64.1.74.1.84.1.94.1.104.1.11

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.tomcat:tomcat, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    A fix is available for CVE-2009-0781; check the affected-versions list above or the advisory for the patched release of org.apache.tomcat:tomcat, then make sure no transitive dependency still pins the vulnerable range.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatLow

Red Hat is aware of this issue and is tracking it via the following bug: https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=CVE-2009-0781 The Red Hat Product Security has rated this issue as having low security impact, a future update may address this flaw. More information regarding issue severity can be found…

ProductFixed inAdvisory
Red Hat Enterprise Linux 5tomcat5-0:5.5.23-0jpp.7.el5_3.2RHSA-2009:1164
RHAPS Version 2 for RHEL 4tomcat5-0:5.5.23-0jpp_4rh.16RHSA-2009:1562

Frequently Asked Questions

Cross-site scripting (XSS) vulnerability in jsp/cal/cal2.jsp in the calendar application in the examples web application in Apache Tomcat 4.1.0 through 4.1.39, 5.5.0 through 5.5.27, and 6.0.0 through 6.0.18 allows remote attackers to inject arbitrary web script or HTML via the time parameter, related to "invalid HTML."
O3 Security · Impact-Aware SCA

Is CVE-2009-0781 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2009-0781: tomcat XSS — Fixed in 6.0.20