CVE-2009-0580 — tomcat
CVE-2009-0580 is a Information Exposure vulnerability in org.apache.tomcat:tomcat. 2 public exploit references exist, so weaponization risk is real. A fix is available for org.apache.tomcat:tomcat — see the affected versions and patch details below.
Exposure of Sensitive Information in Apache Tomcat
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
org.apache.tomcat:tomcat☕org.apache.tomcat:tomcat☕org.apache.tomcat:tomcatReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Apache Tomcat 4.1.0 through 4.1.39, 5.5.0 through 5.5.27, and 6.0.0 through 6.0.18, when FORM authentication is used, allows remote attackers to enumerate valid usernames via requests to /j_security_check with malformed URL encoding of passwords, related to improper error checking in the (1) MemoryRealm, (2) DataSourceRealm, and (3) JDBCRealm authentication realms, as demonstrated by a % (percent) value for the j_password parameter.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.tomcat:tomcat | ≥ 4.1.0&&< 4.1.40 | 4.1.40org.apache.tomcat:tomcat:4.1.40 |
| ☕Maven | org.apache.tomcat:tomcat | ≥ 5.0.0&&< 5.5.28 | 5.5.28org.apache.tomcat:tomcat:5.5.28 |
| ☕Maven | org.apache.tomcat:tomcat | ≥ 6.0.0&&< 6.0.19 | 6.0.19org.apache.tomcat:tomcat:6.0.19 |
Affected Products
tomcatapacheResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Apache Tomcat 6.0.18 - Form Authentication Existing/Non-Existing 'Username' Enumeration
by D. Matscheko · Jun 3, 2009
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.tomcat:tomcat, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.tomcat:tomcat to 4.1.40 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2009-0580 is resolved across your whole dependency graph.
Workarounds
Assume what was exposed is already known: rotate any credential, token or key that the affected component could return, restrict the endpoint to callers that genuinely need it, and strip sensitive fields from responses and error output at the boundary rather than relying on the client not to read them.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
| Product | Fixed in | Advisory |
|---|---|---|
| JBEAP 4.2.0 for RHEL 4 | hibernate3-1:3.2.4-1.SP1_CP08.0jpp.ep1.2.el4 | RHSA-2009:1144 |
| JBEAP 4.2.0 for RHEL 5 | hibernate3-1:3.2.4-1.SP1_CP08.0jpp.ep1.2.3.el5 | RHSA-2009:1143 |
| JBEWS 1.0 for RHEL 4 | tomcat5-0:5.5.23-1.patch07.19.ep5.el4 | RHSA-2009:1454 |
| JBEWS 1.0 for RHEL 4 | tomcat6-0:6.0.18-11.3.ep5.el4 | RHSA-2009:1506 |
| Red Hat Certificate System 7.3 | ant-0:1.6.5-1jpp_1rh | RHSA-2010:0602 |
| Red Hat Developer Suite V.3 | tomcat5-0:5.5.23-0jpp_18rh | RHSA-2009:1563 |
| Red Hat Enterprise Linux 5 | tomcat5-0:5.5.23-0jpp.7.el5_3.2 | RHSA-2009:1164 |
| Red Hat JBoss Enterprise Application Platform 4.3 for RHEL 4 | glassfish-jaxb-0:2.1.4-1.11.ep1.el4 | RHSA-2009:1146 |
Frequently Asked Questions
Is CVE-2009-0580 in your dependencies?
Find it across Maven, including transitive dependencies.