NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
Withdrawn — this advisory has been retracted
📦 Debian:10
Not in CISA KEV

CVE-2009-0312 — moin

CVE-2009-0312 is a Cross-site Scripting (XSS) vulnerability in moin. A fix is available for moin — see the affected versions and patch details below.

MoinMoin Cross-site scripting (XSS) vulnerability in the antispam feature

Also known asGHSA-cx94-3h5x-cc57PYSEC-2026-676
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
2.4%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs84th percentile — riskier than 84% of all scored CVEsHighest risk
0.17%1.07%1.97%2.87%0.7%2.4%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

1 pkg affected
📦moin

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Debian:10 packages — download data is not available via public APIs for these ecosystems.

Description

Cross-site scripting (XSS) vulnerability in the antispam feature (security/antispam.py) in MoinMoin 1.7 and 1.8.1 allows remote attackers to inject arbitrary web script or HTML via crafted, disallowed content.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦Debian:10moinall versions1.8.1-1.1

Affected Products

1 product · 2 configurations
Application
moinmoinmoinmoin
2 versions
1.7.01.8.1

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for moin, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update moin to 1.8.1-1.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2009-0312 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

Cross-site scripting (XSS) vulnerability in the antispam feature (security/antispam.py) in MoinMoin 1.7 and 1.8.1 allows remote attackers to inject arbitrary web script or HTML via crafted, disallowed content.
O3 Security · Impact-Aware SCA

Is CVE-2009-0312 in your dependencies?

Find it across Debian:10, including transitive dependencies.

CVE-2009-0312: moin XSS — Fixed in 1.8.1-1.1