NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
Withdrawn — this advisory has been retracted
📦 Debian:10
Not in CISA KEV

CVE-2009-0260 — moin

CVE-2009-0260 is a Cross-site Scripting (XSS) vulnerability in moin. 2 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for moin — see the affected versions and patch details below.

MoinMoin Multiple cross-site scripting (XSS) vulnerabilities

Also known asGHSA-7hjm-hqgj-xv9fPYSEC-2026-670
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
2 known
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
5.5%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs93th percentile — riskier than 93% of all scored CVEsHighest risk
2.31%3.61%4.91%6.21%3.0%5.5%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

1 pkg affected
📦moin

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Debian:10 packages — download data is not available via public APIs for these ecosystems.

Description

Multiple cross-site scripting (XSS) vulnerabilities in action/AttachFile.py in MoinMoin before 1.8.1 allow remote attackers to inject arbitrary web script or HTML via an AttachFile action to the WikiSandBox component with (1) the rename parameter or (2) the drawing parameter (aka the basename variable).

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦Debian:10moinall versions1.8.1-1.1

Affected Products

1 product · 36 configurations
Application
moinmoinmoinmoin
≤ 1.8.0
35 versions
0.10.20.30.70.80.90.100.111.01.11.21.2.1
Exploits & PoCs
2

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

EDB-32746webappscgi✓ Verified

MoinMoin 1.8 - 'AttachFile.py' Cross-Site Scripting

by SecureState · Jan 20, 2009

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for moin, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update moin to 1.8.1-1.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2009-0260 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

Multiple cross-site scripting (XSS) vulnerabilities in action/AttachFile.py in MoinMoin before 1.8.1 allow remote attackers to inject arbitrary web script or HTML via an AttachFile action to the WikiSandBox component with (1) the rename parameter or (2) the drawing parameter (aka the basename variable).
O3 Security · Impact-Aware SCA

Is CVE-2009-0260 in your dependencies?

Find it across Debian:10, including transitive dependencies.

CVE-2009-0260: moin XSS — Fixed in 1.8.1-1.1