NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕ Maven
Not in CISA KEV

CVE-2009-0026 — jackrabbit

Fix: apache/jackrabbit@36330ae

CVE-2009-0026 is a Cross-site Scripting (XSS) vulnerability in org.apache.jackrabbit:jackrabbit. 4 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for org.apache.jackrabbit:jackrabbit — see the affected versions and patch details below.

Apache Jackrabbit contains Cross-site Scripting

Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
4 known
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
26.8%probability of exploitation in next 30 days
Moderate Risk0.00%
Lower risk than most CVEs98th percentile — riskier than 98% of all scored CVEsHighest risk
16.1%25.9%35.8%45.6%40.1%26.8%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

1 pkg affected
☕org.apache.jackrabbit:jackrabbit

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Multiple cross-site scripting (XSS) vulnerabilities in Apache Jackrabbit before 1.5.2 allow remote attackers to inject arbitrary web script or HTML via the q parameter to (1) search.jsp or (2) swr.jsp.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.apache.jackrabbit:jackrabbitall versions1.5.2org.apache.jackrabbit:jackrabbit:1.5.2

Affected Products

1 product · 2 configurations
Application
jackrabbitapache
2 versions
1.41.5.0
Exploits & PoCs
4

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

EDB-32741webappsjsp✓ Verified

Apache JackRabbit 1.4/1.5 Content Repository (JCR) - 'search.jsp?q' Cross-Site Scripting

by Red Hat · Jan 20, 2009

EDB-32742webappsjsp✓ Verified

Apache JackRabbit 1.4/1.5 Content Repository (JCR) - 'swr.jsp?q' Cross-Site Scripting

by Red Hat · Jan 20, 2009

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.jackrabbit:jackrabbit, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.apache.jackrabbit:jackrabbit to 1.5.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2009-0026 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

Multiple cross-site scripting (XSS) vulnerabilities in Apache Jackrabbit before 1.5.2 allow remote attackers to inject arbitrary web script or HTML via the q parameter to (1) search.jsp or (2) swr.jsp.
O3 Security · Impact-Aware SCA

Is CVE-2009-0026 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2009-0026: jackrabbit XSS — Fixed in 1.5.2