NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
Withdrawn — this advisory has been retracted
📦
📦 Debian:10
Not in CISA KEV
HIGH severity

CVE-2008-6549 — moin

HIGH

CVE-2008-6549 is a high-severity (CVSS 7.5) vulnerability in moin. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for moin — see the affected versions and patch details below.

MoinMoin Denial of Service vulnerability via password_checker function

Also known asGHSA-wjjc-m3fc-fcm8PYSEC-2009-12
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Oct 30, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.5%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs74th percentile — riskier than 74% of all scored CVEsHighest risk
0.04%0.69%1.34%1.98%0.5%1.5%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
📦moin

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Debian:10 packages — download data is not available via public APIs for these ecosystems.

Description

The password_checker function in config/multiconfig.py in MoinMoin prior to version 1.6.1 uses the cracklib and python-crack features even though they are not thread-safe, which allows remote attackers to cause a denial of service (segmentation fault and crash) via unknown vectors.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦Debian:10moinall versions1.6.2-1

Affected Products

1 product · 1 configurations
Application
moinmoinmoinmo
1 version
1.6.1
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for moin, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update moin to 1.6.2-1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2008-6549 is resolved across your whole dependency graph.

  3. Workarounds

    Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.

Frequently Asked Questions

The password_checker function in `config/multiconfig.py` in MoinMoin prior to version 1.6.1 uses the cracklib and python-crack features even though they are not thread-safe, which allows remote attackers to cause a denial of service (segmentation fault and crash) via unknown vectors.
O3 Security · Impact-Aware SCA

Is CVE-2008-6549 in your dependencies?

Find it across Debian:10, including transitive dependencies.

CVE-2008-6549: moin DoS — Fixed in 1.6.2-1