NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕ Maven
Not in CISA KEV

CVE-2008-5720 — mayaa

CVE-2008-5720 is a Cross-site Scripting (XSS) vulnerability in com.github.seasarorg.mayaa:mayaa. A fix is available for com.github.seasarorg.mayaa:mayaa — see the affected versions and patch details below.

Mayaa Cross-site Scripting vulnerability

Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Oct 31, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.3%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs70th percentile — riskier than 70% of all scored CVEsHighest risk
0.00%0.59%1.18%1.76%0.5%1.3%May 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

1 pkg affected
☕com.github.seasarorg.mayaa:mayaa

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Cross-site scripting (XSS) vulnerability in Mayaa before 1.1.23 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors involving the default error page for the org.seasar.mayaa.impl.engine.PageNotFoundException exception and possibly other exceptions.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavencom.github.seasarorg.mayaa:mayaaall versions1.1.23com.github.seasarorg.mayaa:mayaa:1.1.23

Affected Products

1 product · 68 configurations
Application
mayaaseasar
≤ 1.1.22
57 versions
0.1.00.1.0f0.1.10.1.20.1.30.2.00.3.00.4.00.9.00.9.10.9.20.9.3

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for com.github.seasarorg.mayaa:mayaa, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update com.github.seasarorg.mayaa:mayaa to 1.1.23 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2008-5720 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

Cross-site scripting (XSS) vulnerability in Mayaa before 1.1.23 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors involving the default error page for the `org.seasar.mayaa.impl.engine.PageNotFoundException` exception and possibly other exceptions.
O3 Security · Impact-Aware SCA

Is CVE-2008-5720 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2008-5720: mayaa XSS — Fixed in 1.1.23